¿Cómo uso la función ESERROR en Excel? [3 esempi facili]


El La función ESERROR ES en Excel es parte de la categoría Funciones de información. Si el valor proporcionado representa un error, la función devolverá VERDADERO; de lo contrario, devolverá FALSO. #NOMBRE?, #NUM!, #N/A, #REF!, #VALOR!, #DIV/0! un #NULO todos son errores válidos.

El La función ESERROR en Excel se usa junto con la función IF para detectar un posible error de fórmula y mostrar otras fórmulas o cadenas de texto como mensajes o espacios en blanco. Si se encuentra un error, también se puede usar con la función IF para mostrar un mensaje personalizado o realizar otros cálculos.

Tenemos que lidiar con algoritmos y datos en el análisis financiero. Nuestra hoja de cálculo suele tener una gran cantidad de fórmulas y no siempre se comporta como se espera.

Fórmula: =ISERROR(valor)

La función ESERROR en Excel aplicar el argumento como se muestra a continuación:

Valor: esta es la celda objetivo que desea probar. Se da principalmente como una dirección de celular.

Así que desplácese hacia abajo a esta publicación para saber cómo usar Función de ERROR en Excel

¿Cómo usar la función ESERROR en Excel?

Considere los siguientes escenarios para comprender mejor ESERROR Función de Excel :

Ejemplo 1:

Veamos la salida de la función cuando enviamos la siguiente información:

ESERROR Función de Excel

Ejemplo 2:

Podemos usar la función ESERROR incluida en función SUMAPRODUCTO para contar el número de celdas con errores.

Supongamos que nos dan la siguiente información:

La función ESERROR incluida en la función SUMAPRODUCTO

Usando la fórmula =SUMAPRODUCTO(–EMISIÓN(G22:CH27)) podemos obtener el número de celdas con un error como se muestra a continuación.

=SUMAPRODUCTO(–EMISIÓN(G22:CH27))

En la fórmula anterior:

La función SUMPRODUCT tomó una o más matrices y calculó la suma de los productos de los números correspondientes.

Leer:  ¿Cómo corregir el error "La referencia de Microsoft Excel no es válida"?

ISERROR ahora evalúa cada una de las celdas en el rango especificado. el resultado será VERDADERO, FALSO, FALSO, FALSO, VERDADERO, VERDADERO, FALSO, VERDADERO, VERDADERO, VERDADERO, FALSO, FALSO.

Como usamos doble unario, los resultados VERDADERO FALSO fueron transformados en 0 y 1. Los resultados fueron olvidados {0,1,1,1,0,0,1,0,0,0,1,1}.

SUMPRODUCT ahora suma los elementos en la matriz dada y devuelve el total, que en el ejemplo es el número 6.

Alternativamente, puede usar la función SUMA. La fórmula a utilizar será =SUMA(–ESERROR(rango)). No olvides poner la fórmula en una matriz. Para matrices, debemos presionar Control + Mayús + Intro en lugar de simplemente Entrar.

Ejemplo 3:

Aquí, en este caso, veremos por ejemplo si queremos dar un mensaje personalizado, por ejemplo, en lugar de recibir Error #DIV/0 queremos que el valor sea 0. Podemos usar la fórmula =SI(EMISIÓN(A4/B4),0, A4/B4) en lugar de A4/B4.

Supongamos que tenemos los siguientes datos:

Error #DIV/0

En lugar de VERDADERO si queremos ingresar el valor 0, la fórmula a utilizar será =SI(EMISIÓN(B6),0,B6) y no B6 como se muestra a continuación:

=SI(ERROR(B6),0,B6)

Obtenemos la salida a continuación como se muestra:

Usar funciones de Excel EN CASO DE ERROR

Método de reemplazo de valor manual ERROR

Sin embargo, podemos usar la fórmula ISERROR para reemplazar el error; Hay un enfoque manual para hacer esto: el método de buscar y reemplazar.

  1. Después de aplicar la fórmula, copiar y pegar justo Los valores.
  2. Abrir caja de cambios para empujar Ctrl+H e ingrese el valor del error (#N/A, #DIV/0!, etc.). Tenga en cuenta el tipo de error que desea sustituto.
  3. Reemplazar «Fecha no encontrada» para el reemplazo con valores.
  4. Seleccionar Reemplazar todo del menú desplegable.

Como resultado, todos los valores de error especificados anteriormente se reemplazarán con Datos no encontrados.

Leer:  Solucione el error "Excel encontró contenido no leído en nombre de archivo.xls" en el archivo de MS Excel

Usar: si ha aplicado un filtro, debe usar la técnica Solo celdas visibles para reemplazarlos.

Cosas para recordar:

Función de Excel ESERROR puede embellecer sus informes numéricos eliminando todo tipo de errores. Si los datos contienen un tipo de error y se usa una tabla dinámica, el error también aparecerá en la tabla dinámica. Al detectar valores incorrectos, ISERROR puede mejorar la apariencia del informe y ahorrarle vergüenza. Solo una celda a la vez puede verse afectada por ISERROR. No puede tomar muchos rangos de celdas. Cuando se aplica a un rango de celdas, solo se considera la primera celda del rango.

Aparte de eso, si tiene problemas con Excel, le recomiendo que descargue el poderoso Herramienta de reparación de Excel. Esta herramienta avanzada puede corregir todos sus errores y problemas de Corrupción de Excel. No solo esta herramienta también puede restaurar fórmulas, gráficos, tablas, hojas de gráficos, filtros, clasificaciones, comentarios de celdas.

Si tiene alguna pregunta relacionada con este tema, compártala con nosotros en nuestra página oficial. Facebook mi Gorjeo y no olvides darle me gusta y compartir esta publicación con tus amigos…

Suerte….

Margarita

Margret Arthur es emprendedora y experta en marketing de contenidos. Escribe blogs sobre tecnología y habilidades en MS Office, Excel y otros temas técnicos. Su arte distintivo de presentar información técnica en un lenguaje fácil de entender es muy impresionante. cuando no está escribiendo, le gusta hacer viajes no planificados.

Últimas Entradas Publicadas

5 Problemas y soluciones de la función CONTAR.SI de Excel

¿Es usted el que enfrenta varios problemas al usar la función COUNTIF en Excel, que este artículo es para usted? ...

11 trucos de depuración de Excel simples pero potentes para analizar datos

Casi todo el trabajo que la mayoría de los oficinistas hacen con la ayuda de un programa mágico llamado Microsoft ...

Los 3 mejores métodos para desbloquear archivos de Excel protegidos con contraseña

Resumen: En este blog, hablaré sobre todos los aspectos. archivo de Excel seguro contraseña y cómo desbloqueo de archivos xlsx ...

Solucione el error «Excel encontró contenido no leído en nombre de archivo.xls» en el archivo de MS Excel

Microsoft Excel es una hoja de cálculo desarrollada específicamente para que los usuarios organicen, calculen y formatee datos con fórmulas ...

5 formas de arreglar MS Excel 2016 dejó de funcionar en Windows 10

el tuyo lo hace Excel 2016 ha dejado de funcionar en Windows 10 y no sabe cómo deshacerse de este ...

Métodos 3 para recuperar un archivo de Excel que se ha guardado

¿Es usted el que busca algunos trucos fáciles para recuperar los archivos guardados de Excel que desaparecen repentinamente? Bueno, todos ...

¿Cómo reparar el error 400 de VBA al ejecutar la macro de Excel?

¿Está recibiendo un cuadro de diálogo de error llamado Microsoft Excel que solo contiene el número 400? O recibiendo el ...

3 formas de solucionar el problema de Excel Textjoin que no funciona

Tienes problemas para usarlo ¿Función TEXTJOIN en Excel 2016? Buscando soluciones rápidas para solucionarlo La función TEXTJOIN en Excel 2016 ...

¿Cómo reparar el error de carga del complemento Excel Solver?

El complemento Solver es un complemento de Microsoft Excel que puede encontrar rápidamente problemas simples, como los valores de una ...

¿Cómo crear un diagrama de flujo en Excel? (Guía paso por paso)

MS Excel es el programa de hoja de cálculo comúnmente utilizado para formatear y organizar grandes cantidades de datos. No ...

Leave a Reply

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *